File diff r20927:6e37de998bbe → r20928:e6a1e0b8d890
os/debian/rules
Show inline comments
 
@@ -14,13 +14,13 @@ endif
 

	
 
# Pass custom options to configure. Since it's not autoconf but a custom
 
# script, some of the option names are slightly different. We also need
 
# to be explicit about the dependencies, in case we're not running in a
 
# clean build root.
 
override_dh_auto_configure:
 
	./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --with-lzma --without-iconv --disable-strip CFLAGS="$(CFLAGS) -g" LDFLAGS="$(LDFLAGS) -Wl,-as-needed"
 
	./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --with-lzma --with-xdg-basedir --without-iconv --disable-strip CFLAGS="$(CFLAGS) -g" LDFLAGS="$(LDFLAGS) -Wl,-as-needed"
 

	
 
# Do some extra installation
 
override_dh_auto_install:
 
	$(MAKE) install DO_NOT_INSTALL_CHANGELOG=1 DO_NOT_INSTALL_LICENSE=1
 

	
 
	# Install the wrapper and make it executable