File diff r18374:ea9fdd784480 → r18375:af3d1f9949fb
os/rpm/openttd.spec
Show inline comments
 
@@ -108,25 +108,25 @@ OpenTTD is a reimplementation of the Mic
 
with lots of new features and enhancements. To play the game you need either
 
the original data from the game or the required package OpenGFX and OpenSFX.
 

	
 
This package is required by openttd gui and openttd dedicated package. This
 
way it is possible to install a openttd version without SDL requirement.
 

	
 
%endif
 

	
 
%prep
 
%setup -qn openttd%{?branch:-%{branch}}-%{srcver}
 

	
 
# we build the grfs from sources but validate the result with the existing data
 
md5sum bin/data/* > validate.data
 
md5sum bin/baseset/* > validate.data
 

	
 
%build
 
./configure \
 
        --prefix-dir="%{_prefix}" \
 
        --binary-name="%{binname}" \
 
        --binary-dir="bin" \
 
        --data-dir="share/%{binname}" \
 
        --doc-dir="share/doc/%{binname}" \
 
        --menu-name="OpenTTD%{?branch: %{branch}}" \
 
        --menu-group="Game;StrategyGame;" \
 
        --enable-dedicated="%{dedicated}" \
 

	
 
@@ -174,26 +174,24 @@ md5sum -c validate.data
 
%{_datadir}/icons/hicolor/32x32/apps/%{binname}.png
 
%{_datadir}/icons/hicolor/48x48/apps/%{binname}.png
 
%{_datadir}/icons/hicolor/64x64/apps/%{binname}.png
 
%{_datadir}/icons/hicolor/128x128/apps/%{binname}.png
 
%{_datadir}/icons/hicolor/256x256/apps/%{binname}.png
 
%{_datadir}/pixmaps/%{binname}.32.xpm
 

	
 
%files data
 
%defattr(-, root, root)
 
%dir %{_datadir}/doc/%{binname}
 
%dir %{_datadir}/%{binname}
 
%dir %{_datadir}/%{binname}/lang
 
%dir %{_datadir}/%{binname}/data
 
%dir %{_datadir}/%{binname}/gm
 
%dir %{_datadir}/%{binname}/baseset
 
%dir %{_datadir}/%{binname}/scripts
 
%dir %{_datadir}/%{binname}/ai
 
%{_datadir}/doc/%{binname}/*
 
%{_datadir}/%{binname}/lang/*
 
%{_datadir}/%{binname}/data/*
 
%{_datadir}/%{binname}/baseset/*
 
%{_datadir}/%{binname}/scripts/*
 
%{_datadir}/%{binname}/ai/*
 
%{_datadir}/%{binname}/gm/*
 
%doc %{_mandir}/man6/%{binname}.6.*
 
%endif
 

	
 
%changelog