Files @ r7811:5a33f2f08b6e
Branch filter:

Location: cpp/openttd-patchpack/source/os/debian/rules

miham
(svn r11361) -Update: WebTranslator2 update to 2007-10-30 19:53:53
afrikaans - 211 fixed, 22 changed by TrueTenacity (233)
brazilian_portuguese - 2 fixed by fukumori (2)
bulgarian - 3 fixed by thetitan (3)
catalan - 3 fixed, 1 changed by arnaullv (4)
croatian - 49 fixed by knovak (49)
czech - 51 fixed by Hadez (51)
danish - 55 fixed by ThomasA (55)
dutch - 2 fixed by habell (2)
estonian - 52 fixed by t2t2 (7), kristjans (45)
french - 2 fixed by Skiper (2)
german - 56 fixed by moewe2 (56)
italian - 3 fixed, 1 changed by lorenzodv (4)
japanese - 56 fixed by ickoonite (56)
latvian - 38 fixed by Gustavo (38)
norwegian_nynorsk - 56 fixed by pollux (56)
romanian - 55 fixed, 3 changed by CrystyB (16), kneekoo (42)
russian - 3 fixed by Smoky555 (3)
slovak - 2 fixed, 4 changed by lengyel (6)
slovenian - 3 fixed by Necrolyte (3)
spanish - 4 fixed by eusebio (4)
traditional_chinese - 55 fixed by xbddc (55)
ukrainian - 3 fixed, 10 changed by fevral13 (3), mad (10)
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

include /usr/share/dpatch/dpatch.make

configure: patch configure-stamp
configure-stamp:
	dh_testdir
	# Add here commands to configure the package.

	touch configure-stamp


build: configure build-stamp
build-stamp:
	dh_testdir

	# Add here commands to compile the package.
	
	./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/openttd
	$(MAKE)

	#/usr/bin/docbook-to-man debian/openttd.sgml > openttd.1

	touch build-stamp

clean: unpatch
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# Add here commands to clean up after the build process.
	-$(MAKE) clean

	dh_clean

install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs

	# Add here commands to install the package into debian/openttd.
	$(MAKE) install

# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.

# Build architecture-dependent files here.
binary-arch: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs changelog.txt
	dh_installdocs
	dh_installexamples
#	dh_install
	dh_installmenu
	dh_installdebconf
#	dh_installlogrotate
#	dh_installemacsen
#	dh_installpam
#	dh_installmime
#	dh_installinit
#	dh_installcron
#	dh_installinfo
	dh_installman docs/openttd.6
	dh_link
	dh_strip
	dh_compress
	dh_fixperms
#	dh_perl
#	dh_python
#	dh_makeshlibs
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure patch